What are the system requirements for the Cogmed Platform?

The system requirements for the new platform are any modern browser on a computer, tablet or mobile phone with a reliable Internet connection. We do not recommend training on mobile phones due to the smaller screen and distracting environments.

Recommended browsers are Google Chrome, Mozilla Firefox, Microsoft Edge or Apple Safari. The Cogmed platform does not support Internet Explorer.

If you cannot login or have problems accessing the Cogmed platform:

1. Make sure you are using the latest version of your browser. 
2. Try logging in with another browser.